Running Svn2Svn gives "Client too old error"

Apr 26, 2009 at 1:54 PM

Collecting svn log: This client is too old to work with working copy 'D:\POC
_Of_SVNs\SourceSVN'.  You need
to get a newer Subversion client, or to downgrade this working copy.
See http://subversion.tigris.org/faq.html#working-copy-format-change
for details.

I went to the link mentioned above. I got a Python file as well however there are proper steps to run this file.

Any pointers ....
Coordinator
Apr 27, 2009 at 3:02 AM
You checked out D:\POC_Of_SVNs\SourceSVN with a version of SVN that's too new for Svn2svn. The tool uses sharpsvn, the latest version, so I don't think there's much I can do about this. I think you're going to have to downgrade to an older version of a subversion client, get your source from svn again and restart.
Apr 27, 2009 at 9:03 AM
Yeah Thanks. I thought that probably Svn2Svn uses an older version of SVN which you confirmed, But couple of questions .
A) Which exact version number does SVN2SVN uses . You mentioned Sharpsvn but does it internally use some version of 'Tortoise SVN'
B) How do I get an older versions of SVN as currently I am using "TortoiseSVN-1.6.1.16129-win32-svn-1.6.1" . Are the older versions available for Download.
Coordinator
Apr 27, 2009 at 12:08 PM
Looks like the version of svn in SharpSVN is 1.5.5.34862.
Older releases are available from http://sourceforge.net/project/showfiles.php?group_id=138498&package_id=151948. I got the link from Older Files under http://tortoisesvn.net/downloads. 
Let me know if that works.
Apr 27, 2009 at 12:12 PM
Hi dblock,

I went to following link and got the info that SharpSVN uses 1.5 version of SVN . Please confirm.
http://sharpsvn.open.collab.net/
  > Features

Regards,
lalrow
Apr 27, 2009 at 12:14 PM
Hi dblock,

I posted my previous message before reading your latest one . Ignore the same. 

Regards,
lalrow
Apr 27, 2009 at 10:23 PM
Hi Dblock, 
Thanks I was able to install the older version of tortoise SVN and have got rid of that error . However it is giving me this error now . Any quick pointers .

C:\>Svn2Svn /source:D:\Eon\POC_Of_SVNs\Source\Mapping_v1.5.0.xls /destination:D:\Eon\POC_Of_SVNs\Destination\Data_Model
Svn2Svn: 1.0.12201.0
From: D:\Eon\POC_Of_SVNs\Source\Mapping_v1.5.0.xls
To: D:\Eon\POC_Of_SVNs\Destination\Data_Model
Collecting svn log: Source SVN root: <Root path >
Source SVN uri: <UriofDestination>Mapping_v1.5.0.xls
Relative path: /<SVNpath>Mapping_v1.5.0.xls
...........
Collected 11 revisions.
Revision 369 (3/31/2009 4:38:40 AM)
Can't move 'D:\Eon\POC_Of_SVNs\Destination\Data_Model.tmp' to 'D:\Eon\POC_Of_SVN
s\Destination\Data_Model': Access is denied.
Apr 28, 2009 at 2:56 PM
Hi ,

Does it have to do something with my credentials ?

Regards,
lalrow
May 4, 2009 at 2:35 PM
Hi ,

Any updates on this ?

Regards,
lalrow
Coordinator
May 5, 2009 at 8:48 PM
Sorry for the late reply. What svn2svn is trying to do is an svn export -r 369 D:\Eon\POC_Of_SVNs\Destination\Data_Model. But you're moving a single file to a folder? Maybe you just need to specify the destination filename Svn2Svn /source:D:\Eon\POC_Of_SVNs\Source\Mapping_v1.5.0.xls /destination:D:\Eon\POC_Of_SVNs\Destination\Data_Model\Mapping_v1.5.0.xls ?
Nov 17, 2009 at 1:43 PM

Hi dblock,

congratulations for this tiny useful program. Now Sharpsvn is available also for Subversion 1.6.xx: http://sharpsvn.open.collab.net/files/documents/180/2341/SSvn-1.6003.1304.zip. What about building and distributing an updated svn2svn? (Which I could use on my TortoiseSVN 1.6 working copies...)

Thanks

Nicola

Nov 26, 2009 at 10:19 AM

Hi dblock,

no news about svn2svn with SSvn 1.6? Apologies if this bothers...

Thanks

Nicola

Coordinator
Nov 29, 2009 at 7:51 PM

I updated to SharpSVN 1.6, that claims to support SVN 1.6.

http://svn2svn.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=36561

I didn't really test it. Let me know if this works.